Single Sign On issue with Hayylo Web
Incident Report for Hayylo
Postmortem

Incident Summary:
On the morning of December 6, 2024, users attempting to log into the Hayylo platform via Single Sign-On (SSO) experienced login failures.

Root Cause:
The issue was caused by an infrastructure change that introduced a logging directory permission error. This error prevented the SSO login service from functioning correctly.

Resolution:
Once identified, the team corrected the directory permissions, restoring functionality to the SSO login process. The issue was resolved at approximately 8:10am for all users, and affected users were informed of the resolution.

Preventive Measures:
We are taking the following actions to prevent similar issues in the future:

  1. Implementing additional automated testing and validation during infrastructure changes.
  2. Strengthening logging and alerting to quickly detect and isolate permission-related issues.
  3. Updating deployment processes to include directory permission checks as part of standard procedures.

We apologise for any inconvenience this incident may have caused and appreciate your understanding.

If you have any further questions or concerns, please contact our support team.

Thank you,
The Hayylo Team

Posted Dec 06, 2024 - 16:03 AEDT

Resolved
The SSO issue has now been resolved. All users can now login to the Hayylo web interface as normal.
Posted Dec 06, 2024 - 08:31 AEDT
Investigating
We are currently investigating an issue that is preventing users from logging in via Single Sign On. We will update as soon as we have further details.
Posted Dec 06, 2024 - 07:43 AEDT
This incident affected: Hayylo Web.